[horde] Horde isn't working anymore (after a freebsd update?)

Dirk Dettmering horde-lists at dettmering.org
Mon Jul 23 22:09:34 UTC 2012

Ralf Lang wrote:
> Am 18.07.2012 19:48, schrieb Dirk Dettmering:
>> since around 2 or 3 weeks my private horde installation isn't
>> working anymore and I can't find the culprit. It's a freebsd 8.3
>> system (32 bit version, last updated Jul 2) and horde was installed
>> in may 2011 the horde way and not via ports. I guess that the
>> problem is caused by an update of a port and not by horde itself
>> but maybe somebody on this list can give me a hint. The system is
>> used by me and my family only when we are abroad. Therefore I can't
>> say exactly when horde stopped working.
>> The startpage just states: Ein schwerer Fehler ist aufgetreten:
>> Class does not exist
> Suggestions:
> Disable memcache in conf.php

No Change.

> Purge Horde_Autoloader cache (is the Horde_Autoloader_Cache installed)
> Install xdebug

I already installed xdebug but had no time till today to read the 
documentation how to set it up to debug horde.

> See php log (usually syslog or something configured in php.ini) WHICH
> classes are missing.

I can't find any more information in the logs.

> what's your horde version and php version?

pear list -c pear.horde.org

Installed packages, channel pear.horde.org:
Package                   Version State
Horde_ActiveSync          1.2.7   stable
Horde_Alarm               1.0.7   stable
Horde_Argv                1.0.5   stable
Horde_Auth                1.4.9   stable
Horde_Autoloader          1.0.1   stable
Horde_Browser             1.0.8   stable
Horde_Cache               1.0.5   stable
Horde_Cli                 1.0.4   stable
Horde_Compress            1.0.7   stable
Horde_Constraint          1.0.1   stable
Horde_Controller          1.0.2   stable
Horde_Core                1.9.2   stable
Horde_Crypt               1.1.2   stable
Horde_Data                1.0.7   stable
Horde_DataTree            1.0.1   stable
Horde_Date                1.0.11  stable
Horde_Date_Parser         1.0.2   stable
Horde_Db                  1.2.1   stable
Horde_Editor              1.0.2   stable
Horde_Exception           1.0.9   stable
Horde_Feed                1.1.1   stable
Horde_Form                1.1.0   stable
Horde_Group               1.0.5   stable
Horde_History             1.0.1   stable
Horde_Http                1.1.1   stable
Horde_Icalendar           1.1.2   stable
Horde_Image               1.0.10  stable
Horde_Imap_Client         1.5.5   stable
Horde_Imsp                1.0.6   stable
Horde_Injector            1.0.1   stable
Horde_Itip                1.0.7   stable
Horde_Kolab_Format        1.1.2   stable
Horde_Kolab_Server        1.0.2   stable
Horde_Kolab_Session       1.1.1   stable
Horde_Kolab_Storage       1.1.0   stable
Horde_Ldap                1.1.5   stable
Horde_Lock                1.0.1   stable
Horde_Log                 1.1.2   stable
Horde_LoginTasks          1.0.3   stable
Horde_Mail                1.2.0   stable
Horde_Memcache            1.1.1   stable
Horde_Mime                1.6.1   stable
Horde_Mime_Viewer         1.0.8   stable
Horde_Nls                 1.1.6   stable
Horde_Notification        1.0.1   stable
Horde_Oauth               1.0.2   stable
Horde_Pdf                 1.0.2   stable
Horde_Perms               1.0.7   stable
Horde_Prefs               1.1.8   stable
Horde_Rdo                 1.2.0   stable
Horde_Role                1.0.0   stable
Horde_Routes              1.1.2   stable
Horde_Rpc                 1.0.4   stable
Horde_Scribe              1.0.2   stable
Horde_Secret              1.0.2   stable
Horde_Serialize           1.0.2   stable
Horde_Service_Facebook    1.1.3   stable
Horde_Service_Twitter     1.1.4   stable
Horde_Service_Weather     1.1.2   stable
Horde_SessionHandler      1.0.5   stable
Horde_Share               1.3.0   stable
Horde_SpellChecker        1.0.1   stable
Horde_Stream_Filter       1.1.0   stable
Horde_Stream_Wrapper      1.0.1   stable
Horde_Support             1.0.2   stable
Horde_SyncMl              1.0.9   stable
Horde_Template            1.0.1   stable
Horde_Text_Diff           1.0.2   stable
Horde_Text_Filter         1.1.5   stable
Horde_Text_Filter_Csstidy 1.0.1   stable
Horde_Text_Flowed         1.0.1   stable
Horde_Thrift              1.0.1   stable
Horde_Token               1.1.7   stable
Horde_Translation         1.0.2   stable
Horde_Tree                1.0.1   stable
Horde_Url                 1.0.2   stable
Horde_Util                1.4.0   stable
Horde_Vfs                 1.0.9   stable
Horde_View                1.0.1   stable
Horde_Xml_Element         1.0.1   stable
Horde_Xml_Wbxml           1.0.3   stable
content                   1.0.3   stable
horde                     4.0.15  stable
imp                       5.0.22  stable
ingo                      2.0.9   stable
kronolith                 3.0.17  stable
mnemo                     3.0.6   stable
nag                       3.0.8   stable
timeobjects               1.0.7   stable
turba                     3.0.14  stable
webmail                   4.0.8   stable

Only the update for imp from last frriday is missing. I will install no 
updates until this problem is resolved.

> Does /test.php run if you enable it in conf.php?

Horde Version

     Horde is not correctly configured so no application information can 
be displayed. Please follow the instructions in horde/docs/INSTALL and 
ensure horde/config/conf.php and horde/config/registry.php are correctly 
     Error: Class does not exist

test.php report no other problems.

Horde was working with exactly this configuration until 3 weeks before. 
As there is another freebsd user reporting exactly the same error I 
doubt that it's a problem of my configuration - or at least Beech 
Rintoul and I have the same error in our configurations.
I can also report that all other php software on my system is working as 
My php version is php5-5.4.4.

Best regards


More information about the horde mailing list