[horde] Content_Tagger and Content_Types

Simon Brereton simon.buongiorno at gmail.com
Wed Mar 13 09:55:39 UTC 2013


I'm going to start a new thread - I have two major issues with my git
install at the moment.

Kronolith doesn't have the drop-down arrow that it uses to and
clicking on the link results in:
The Content_Tagger class could not be found. Make sure the Content
application is installed.

 1. Horde_Core_Factory_BlockCollection->create()
 2. Horde_Core_Block_Collection->__construct()
 3. Horde_Registry->getAppDrivers()
 4. Horde_Registry->pushApp()
 5. Horde_Registry->_pushAppError()
 6. Horde_Core_Factory_BlockCollection->create()
 7. Horde_Core_Block_Collection->__construct()
 8. Horde_Registry->getAppDrivers()
 9. Horde_Registry->pushApp()
10. Horde_Registry->callAppMethod()
11. call_user_func_array()
12. Horde_Registry_Application->init()
13. Kronolith_Application->_init()

I got a message that a db schema (nag) needed updating.  When I tried
to update this, I get more dire warnings about the Content_Tagger

Per your advise yesterday, my install_dev.conf has:

// The list of apps to create symlinks for
$apps = array('horde', 'imp', 'kronolith', 'turba', 'ingo', 'mnemo',
'nag', 'passwd', 'Content');

Is this correct?

changing this to "content" doesn't change thngs  (I reran php

It is in the webroot:
mail:/usr/share/git-horde5# ls ../horde-beta/
total 16K
drwxr-xr-x   4 root root 4.0K Mar 12 08:20 ./
drwxr-xr-x 153 root root 4.0K Mar  8 08:31 ../
lrwxrwxrwx   1 root root   33 Mar 12 08:20 admin ->
lrwxrwxrwx   1 root root   31 Mar 12 08:20 bin ->
lrwxrwxrwx   1 root root   34 Mar 12 08:20 config ->
lrwxrwxrwx   1 root root   29 Mar 12 08:20 content ->

The only thing I can find on Google is really old -

But I do have it in registry.php (as a later post on a different
thread by Mike R confirms).

I can solve the nag db update by doing
mail:/usr/share/git-horde5# horde/bin/horde-db-migrate nag up
[  INFO  ] Migrating DB up.
[  INFO  ] Current nag schema version: 11
Migrating to NagFixSmartlists (12)

At this point, imp works, notes works, turba works, passwd works,
kronolith has the above error
and nag has this error:

A fatal error has occurred

Class Content_Types_Manager does not exist

 1. require() /usr/share/git-horde5/nag/index.php:20
 2. Nag_View_List->__construct() /usr/share/git-horde5/nag/list.php:14
 3. Nag_Factory_TagBrowser->create()
 4. Horde_Injector->getInstance()
 5. Horde_Injector->createInstance()
 6. Horde_Injector_Binder_AnnotatedSetters->create()
 7. Horde_Injector_Binder_Implementation->create()
 8. Horde_Injector_Binder_Implementation->_getInstance()
 9. ReflectionClass->newInstanceArgs()
10. Horde_Core_Tagger->__construct()
11. Horde_Injector->getInstance()
12. Horde_Injector->createInstance()
13. Horde_Injector_Binder_AnnotatedSetters->create()
14. Horde_Injector_Binder_Implementation->create()
15. ReflectionClass->__construct()

I provide this information because I think you'll think it's related.

Currently my registery.local.php has:
 72 $app_fileroot = '/usr/share/horde-beta';
 73 $app_webroot = '..';

This is the only way I can get the links to be formatted as
https://webmail.example.net/imp etc.

If I change it to

 72 $app_fileroot = '/usr/share/horde-beta';
 73 $app_webroot = '/';

then I end up with links like https://imp etc. which are unclickable
(manually entering https://webmail.example.net/imp works just fine.

Perhaps this is an issue with the apache server (2.2.16) and the rewriting mod?

I don't think the errors are related to the webroot variable because I
get the same error for those two applications regardless if it is ..
or / - but it wouldn't be the first time I've been wrong :)

Now that I have git updating on a daily basis, it would be super cool
to get this working (I'm loving all the commits to passwd - that can
only be a good thing, right?).



More information about the horde mailing list