[horde] SyncML

Jan Schneider jan at horde.org
Mon Jun 23 08:51:34 UTC 2014

Zitat von Peter Billson <pete at turtle.com>:

> -----Original Message-----
> From: horde-bounces at lists.horde.org [mailto:horde-bounces at lists.horde.org]
> On Behalf Of Jan Schneider
> Sent: Friday, June 20, 2014 2:00 PM
> To: horde at lists.horde.org
> Subject: Re: [horde] SyncML
> Zitat von Peter Billson <pete at turtle.com>:
>> Zitat von Peter Billson <pete at turtle.com>:
>>> *,
>>>    I'm having an issue with a user syncing Outlook to Kronolith using
>>> Funambol.
>>> The user has 295 appointments but Funambol stops after 129.
>>> I'm sure the issue is with the 130th event but my problem is I cannot
>>> determine in what order Kronolith is sending the events so I can't
>>> determine what the 130th event is.
>>>    I've tried no sort (database order),event_start, event_end,
>>> event_uid, and event_modified. Event_end is close but not exactly the
>>> order of the events in horde_syncml_map;
>>>   Can anyone tell me the order the events are sent or suggest a way I
>>> can see the data sent by syncml?
>>> Pete
>> http://wiki.horde.org/SyncML/ProblemReport
>> Thanks for that. It REALLY helped to locate the problem. My original
>> assessment of the issue was wrong. The problem occurs when Fundable
>> comes back for a second packet of data. The first group of events work
>> fine but the second doesn't authenticate for some reason. Log snippet:
>> Maximum message size 125000 approached during add; current size:
>> 124946
>> DEBUG:  Return message completed
>> DEBUG:  Finished at 2014-06-20 12:42:04. Packet logged in
>> /tmp/sync/server_11.xm l
>> DEBUG:  Backend of class Horde_SyncMl_Backend_Horde created
>> DEBUG:  Started at 2014-06-20 16:42:20. Packet logged in
>> /tmp/sync/client_12.xml
>> DEBUG:  Existing session continued: b39fbb2f2495c9ddffa7ed81ce53a503
>> DEBUG:  Authenticated: yes; version: 1.2; message ID: 3; source URI:
>> fol-SVpBT0x
>> EOnBldGU=; target URI: http://webmail2.turtle.com/rpc.php; user:
>> FooMan;
>> charset:
>>  UTF-8; wbxml: no
>> DEBUG:  Created device class Horde_SyncMl_Device_Sync4j
>> DEBUG:  Creating <Sync> output for server changes in database event
>> DEBUG:  Created device class Horde_SyncMl_Device_Sync4j
>> DEBUG:  Sending add from server:
>> 20131213190921.oi5QdbEAPzgt8gY6uSVysg1 at testmail
>> .turtle.com
>> ERR:    API export call for
>> 20131213190921.oi5QdbEAPzgt8gY6uSVysg1 at testmail.turt
>> le.com failed: Permission Denied
>> And I get the API export call error the next 100+ records.
>> The PHP log  shows an error:
>> 2014-06-20T17:20:14+00:00 EMERG: HORDE Session cookies will not work
>> without a FQDN and with a non-empty cookie domain. Either use a fully
>> qualified domain name like "http://www.example.com" instead of
>> "http://example" only, or set the cookie domain in the Horde
>> configuration to an empty value, or enable non-cookie (url-based)
>> sessions in the Horde configuration. [pid
>> 51606 on line 164 of "/usr/share/php/Horde/Session.php"]
>> 2014-06-20T17:20:14+00:00 DEBUG: HORDE 1. Horde_Registry::appInit()
>> /usr/share/horde/index.php:20
>> 2. Horde_Registry->__construct() /usr/share/php/Horde/Registry.php:279
>> 3. Horde_Session->setup() /usr/share/php/Horde/Registry.php:523
>> 1) I am using a FQDN
>> 2) I tried setting $conf['cookie']['domain'] = '' which makes the
>> error go away but no change in sync behavior.
>> 3) I tried setting $conf['session']['use_only_cookies'] = false; which
>> makes no difference.
> This doesn't matter, SyncML doesn't use cookies. Authentication actually
> succeeded. Calling the export() method on one of the applications' APIs
> triggers a permission denied error instead.
> See where that object UID
> (20131213190921.oi5QdbEAPzgt8gY6uSVysg1 at testmail.turtle.com) belongs to. If
> that is a calendar entry, it's event_uid in kronolith_events.
> Then check that the user has actually READ permissions on the event's
> calendar.
> You are correct that it is a calendar entry.
> The calendar_id and the event_creator_id is the same on all 290 events in
> the kronolith_events table. Is there somewhere else to look for permissions?

There are no individual permissions for events, so it doesn't make  
sense that only one event out of the calendar fails. It's of course  
suspicious that the first event from the second client request is  
Since I have no other idea what might cause this, you need to track  
the permission check in Kronolith_Api#export() yourself.

Jan Schneider
The Horde Project

More information about the horde mailing list