[horde] Handler for action "dynamicinit" does not exist.

Michael M Slusarz slusarz at horde.org
Wed Jun 25 06:37:01 UTC 2014

Quoting Ernie Dunbar <maillist at lightspeed.ca>:

> Background: I have the latest Horde Webmail suite running on a Debian
> web server that also happens to host a few hundred other domains. I had
> installed a "dev" version of Horde with the intention of upgrading our
> old Horde installation, because I wanted to make sure that the
> transition was a smooth one. I had Horde and Imp running smoothly up to
> a point, until Imp started to die with the Javascript popup message
> "Handler for action "dynamicinit" does not exist." Oddly enough, Imp
> actually still works - on the first login of the day. If you log out and
> try to log back in, then you start getting this message again. Until the
> next morning, or on another computer.
> In trying to troubleshoot this problem, I searched all the code in Horde
> for "dynamicInit" and found only one place where it was used: in the
> file horde/imp/js/dimpbase.js
> Here's the code:
>  ajax: function(params) {
>  /* Store the requestid locally, so we don't need to
>  * round-trip to the server. We'll re-add it later. */
>  var action, r_id = params.unset('requestid');
>  if (this.init) {
>  action = 'viewPort';
>  } else {
>  // action = 'dynamicInit';
>  action = 'viewPort';
>  if (this.uid) {
>  params.set('msgload', this.uid);
>  }
>  this.init = true;
>  }
> You can see here I also changed the line 'action = dynamicInit' to
> 'action = viewPort'. Doing this merely changes the error message from
> "Handler for action 'dynamicInit' does not exist" to "Handler for action
> 'viewPort' does not exist".
> This is a Javascript file that is supposed to be running in the
> *browser*, so I'm extra baffled as to why this error occurs, nevermind
> the bizarre behaviour with some crazy 24 hour timeout.

This has nothing to do with the browser.  viewPort and dynamicInit are  
the names of actions performed on the server.  The error message you  
are seeing are notifications sent from the *server*.  (You should see  
the same error message in your server logs if the level is high enough).

Your problem seems to be that you are trying to access these actions  
without a valid session.  In Horde 5.1, session timeout AJAX actions  
worked inconsistently.  This has been fixed in Horde 5.2.


Michael Slusarz [slusarz at horde.org]

More information about the horde mailing list