[horde] ActiveSync Problems

Anton Köstlbacher horde3 at dingsbums.org
Thu Jun 26 15:28:59 UTC 2014

Am 26.06.2014 17:13, schrieb Stefan Johänntgen:
> Am 26.06.2014 16:44, schrieb Anton Köstlbacher:
>> Am 26.06.2014 15:16, schrieb Stefan Johänntgen:
>>> Am 26.06.2014 13:22, schrieb Anton Köstlbacher:
>>>> Am 09.05.2014 15:01, schrieb Anton Köstlbacher:
>>>>> - Contacts syncing never completes (Sync-Indicator on the phone),
>>>>> in the
>>>>> logs I see the following errors:
>>>>> 2014-05-09T14:51:01+02:00 ERR: Invalid address book:
>>>>> wia_1mefmoHzIwZqH4C0nA1
>>>>> 2014-05-09T14:51:01+02:00 ERR: [26576] Change message failed when
>>>>> updating
>>>>> After reconnecting the device in Horde Configuration it works again
>>>>> for
>>>>> a few days and then problems occur again. Horde Webmail is uptodate.
>>>>> What could be wrong with my configuration?
>>>> Hi all,
>>>> syncing of calendar now seems to work over a longer period of time,
>>>> but I have still the same problem with syncing my (default) adressbook.
>>>> The problem occurs when I add one simple new adressbook entry on my
>>>> phone after initial configuration of activesync on the phone.
>>>> Any help is appreciated! Thanks!
>>>> Best Regards,
>>>> Anton
>>> the same here. Yesterday I found the solution!
>>> Check in your database table horde_prefs.
>>> There is an entry:
>>> username   | turba |  default_dir  |  xxxxxxxxxxxxxxxxx
>>> There the wrong address is entered in pref_value!
>>> I have edited the entry to the correct address and now it works! ( and i
>>> create a new ActivSync Account in my phone)
>>> Perhaps it is even if you delete the row and then horde these new sets.
>>> (Horde> Address Book Settings> Sync Settings)
>>> The Probelm is probably caused by uppercase and lowercase characters in
>>> the username.
>>> Horde does not write the correct value into the table! Maybe because in
>>> my table instead of "username" that is was "Username"
>>> I wonder if it is also in your neck
>> I just checked horde_prefs: the pref_uid was indeed uppercase
>> User at domain.de, all other prefs uids are lower case. I changed it to
>> lower case. The pref value itself is correct: wia_1mefmoHzIwZqH4C0nA1.
>> I then completly removed the device from horde and the activesync
>> account from the device.
>> Unfortunatly it didn't help. Inital sync works. Adding one addressbook
>> entry leads to never ending sync (and draining the battery) and the
>> same errors in the log.
>> I'm using "protocol version: 14.0, Using Horde_ActiveSync v2.16.7"
>> Syncing already worked with older Horde_ActiveSync versions. Thanks
>> for any further help!
> oh shame-I would have been happy!
> and the directory wia_1mefmoHzIwZqH4C0nA1 is also in the table
> turba_sharesng?
> And remove the device attempts in the Horde ActiveSync Device Overview
> (https://............../horde/admin/activesync.php)
> For me it was definitely the cause! The address 6hYe2Xv-xEgBS688LdRXLw8
> stood in the horde_prefs and indeed it was 71V4RUA0CuRP5iJMLP6HkEA. And
> horde could not put! I've corrected it by hand, and only then it worked.

Just to be sure: You mean "turba_sharesng.share_name" has to be the same 
value as turba default_dir in horde_prefs?

More information about the horde mailing list