[horde] Address AutoComplete for Imp Compose Not Working, Horde Groupware Webmail Edition 5.2.2, Imp 6.2.2, Turba 4.2.2

Andy Dorman adorman at ironicdesign.com
Fri Oct 24 13:58:27 UTC 2014

On 10/24/2014 08:37 AM, Andy Dorman wrote:
> I am sure I have done something really dumb to disable address
> auto-complete in Imp's compose window, but I can not figure out what I
> have set to cause it to stop working.
> Earlier this year address auto-complete worked fine, but this is a beta
> test install.  So we have been experimenting and testing along with
> upgrading and at some point (not exactly sure when) auto-complete
> stopped working.
> Our turba backends.local.php file disables the localsql address book and
> sets up the personal_ldap address book and everything works great except
> auto-complete when composing an email.
> Here is what happens (or more correctly doesn't happen):
> The imp compose window opens, I enable firebug to monitor what is going
> on and start typing a To|CC|BCC address.  When I get to the third char
> ($conf['compose']['ac_threshold'] = 3;) nothing happens.  There is
> nothing in the firebug console log and no net traffic.
> It is as if there are no js actions attached to the address fields in
> the compose window at all.
> So I expect I have set something somewhere in our beta test imp or turba
> configs, prefs or backend settings that has disabled address
> auto-complete so that it is not even loaded into the compose
> window....but I have searched the docs and the files and have found
> nothing that looks like it could turn off address auto-complete.
> One last bit of information, our production webmail installation (very
> old version using the basic interface) uses the same personal_ldap
> address book and settings and address auto-complete works fine there as
> well.
> So does anyone know which innocent-looking imp|turba config, backend, or
> pref setting that could completely disable address auto-complete in the
> imp compose window?
> Thanks in advance for helping me find my silly mistake.

Oh, a quick follow-up.  I just tried reloading the compose window with 
firebug enabled and found that /imp/core/loader.js is returning a 404 
not found error.

I checked our file system and the debian install doesn't even have a 
"core" dir in imp, much less a file /imp/core/loader.js.

I also searched the entire /usr/share/horde/ and /usr/share/php/Horde 
dirs for any file named loader.js and it does not exist.  So possibly 
this is a debian install issue?

Andy Dorman

More information about the horde mailing list