[horde] Standalone Horde server access disabled overnight (wrong username or password)

L A lp.allard.1 at gmail.com
Wed Feb 20 13:44:30 UTC 2019


I have been running Horde on a Centos VPS (located at home) for 7+years
now, and it always worked great.  Yesterday I was using it without issues.
It is configured to use my GMail account as auth backend.

/var/www/html/horde/imp/config/backends.php has this in it:
// IMAP server
$servers['imap'] = array(
    // ENABLED by default; will connect to IMAP port on local server
    'disabled' => false,
    'name' => 'GMail IMAP Server',
    'hostspec' => 'imap.gmail.com',
    'hordeauth' => true,
    'protocol' => 'imap',
    'port' => 993,
    // Plaintext logins are disabled by default on IMAP servers (see RFC
    // [6.2.3]), so TLS is the only guaranteed authentication available by
    // default.
    'secure' => 'ssl',

Like I said this server has worked flawlessly for years.  This morning, I
cannot login to my Horde server.  I get "Login failed because your username
or password was entered incorrectly." at the login page.

I have confirmed that I can login to gmail.com using the same credentials,
and it works.  My android phone also works with gmail without issues.  So
what happened?  Its a major issue because I am managing a condo property
and use this horde install for calendar/tasks/contacts so now I'm locked

Anybody can help?

More information about the horde mailing list