[horde] Standalone Horde server access disabled overnight (wrong username or password)

L A lp.allard.1 at gmail.com
Wed Feb 20 14:29:48 UTC 2019

On Wed, Feb 20, 2019 at 8:44 AM L A <lp.allard.1 at gmail.com> wrote:

> Hello,
> I have been running Horde on a Centos VPS (located at home) for 7+years
> now, and it always worked great.  Yesterday I was using it without issues.
> It is configured to use my GMail account as auth backend.
> /var/www/html/horde/imp/config/backends.php has this in it:
> // IMAP server
> $servers['imap'] = array(
>     // ENABLED by default; will connect to IMAP port on local server
>     'disabled' => false,
>     'name' => 'GMail IMAP Server',
>     'hostspec' => 'imap.gmail.com',
>     'hordeauth' => true,
>     'protocol' => 'imap',
>     'port' => 993,
>     // Plaintext logins are disabled by default on IMAP servers (see RFC
> 3501
>     // [6.2.3]), so TLS is the only guaranteed authentication available by
>     // default.
>     'secure' => 'ssl',
> );
> Like I said this server has worked flawlessly for years.  This morning, I
> cannot login to my Horde server.  I get "Login failed because your username
> or password was entered incorrectly." at the login page.
> I have confirmed that I can login to gmail.com using the same
> credentials, and it works.  My android phone also works with gmail without
> issues.  So what happened?  Its a major issue because I am managing a condo
> property and use this horde install for calendar/tasks/contacts so now I'm
> locked out...
> Anybody can help?

Geez I forgot to add the log's contents:

Feb 20 09:25:52 centos-mail HORDE: [horde] PHP ERROR:
call_user_func_array() expects parameter 1 to be a valid callback, class
'Horde_Deprecated' does not have a method 'verifySignedUrl' [pid 1158 on
line 1196 of "/usr/share/pear/Horde.php"]
Feb 20 09:25:53 centos-mail HORDE: [imp] [login] Mail server denied
authentication. [pid 1158 on line 730 of
Feb 20 09:25:53 centos-mail HORDE: [imp] FAILED LOGIN for XXXXXXX at gmail.com
(XXX.XXX.XXX.XXX) to {imap://imap.gmail.com:993/} [pid 1158 on line 157 of
Feb 20 09:25:53 centos-mail HORDE: [horde] FAILED LOGIN for
XXXXXXX at gmail.com to horde (XXX.XXX.XXX.XXX) [pid 1158 on line 199 of

Would the problem be on Google's side?  Legacy app access is enabled in my
google account (has always been for horde).  I have also ruled out firewall

More information about the horde mailing list