[horde] Install horde with composer

Ferdinand Gruber fer.grub at yahoo.de
Fri Jan 20 17:32:09 UTC 2023

Am 20.01.23 um 16:01 schrieb Brent:
>  Quoting Ferdinand Gruber <fer.grub at yahoo.de>:
>> I haven't been able to get Horde to work since I upgraded my server 
>> to PHP8.
>> Therefore I tried to make a new install of horde with composer on my 
>> server (openSUSE 15.4)
>> As described in https://github.com/horde/horde-deployment#readme I 
>> entered the following commands.
>> |git clone https://github.com/maintaina-com/horde-deployment.git 
>> horde cd /srv/www/htdocs/horde composer install|
>> That worked without problems.
>> I have little experience with composer, so I don't understand the 
>> next instruction in the readme file.
>> "Then copy the main horde config file to point your web server root 
>> to the web/ subdir"
>> From where should I copy what kind of file to what folder? Of course 
>> I backuped all horde files.
>> Is it necessary to set up a new named virtual host to access the new 
>> horde site? Is the new documentroot for 
>> Hoerde|srv/www/htdocs/horde/web ?
>> |
>> Please give me a hint? Thank you in advance.
>> -- 
>> Regards from Austria
>> Ferdinand Gruber
>> -- 
>> Horde mailing list
>> Frequently Asked Questions: http://horde.org/faq/To unsubscribe, 
>> mail: horde-unsubscribe at lists.horde.org
> In my case, my composer install is in "/var/www/html/horde". The 
> webroot becomes "/var/www/html/horde/web" and so I updated my apache 
> config to reflect that location.
> You then just copy 
> "/var/www/html/horde/web/horde/config/conf.php.dist" to 
> "/var/www/html/horde/web/config/conf.php" and then you should be able 
> to connect to the admin interface and start setting things up the way 
> you want.
> brent

Thank you, that helped.

I created a Virtuel Host for Horde on the webserver.

Then I copied the conf.php from the former horde installation to 
/srv/www/htdocs/horde/var/config/horde/. Hope that is okay. Anyway, now 
the Login page of Horde appears in the web browser.

After entering username and password I get this errors:

require_once(/srv/www/htdocs/horde/vendor/vendor/autoload.php): Failed 
to open stream: No such file or directory in 
*/srv/www/htdocs/horde/vendor/horde/horde/rampage.php* on line *2*

*Fatal error*: Uncaught Error: Failed opening required 
(include_path='.:/usr/share/php8:/usr/share/php/PEAR') in 
/srv/www/htdocs/horde/vendor/horde/horde/rampage.php:2 Stack trace: #0 
{main} thrown in */srv/www/htdocs/horde/vendor/horde/horde/rampage.php* 
on line *2*

Regards from Austria
Ferdinand Gruber

More information about the horde mailing list