[horde] Cannot install Horde with composer on openSUSE 15.4

Ferdinand Gruber fer.grub at yahoo.de
Sun Feb 5 22:30:35 UTC 2023

I've been using Horde for almost 20 years now. PHP8 was installed with 
the upgrade to Suse 15.4. Since upgrading to PHP8, Horde has stopped 

Now I tried a new install of Horde with composer. I am sure that I did 
everything correctly according to the instructions on github. I also 
created a virtualHost for Horde using /srv/www/htdocs/horde/web as 

After successful installation I think, that something like an 
installation wizard should appear after calling the Horde site in the 
web-browser. But instead I am redirected to a login page, that of course 
does not exist.

You can examine this on my real site: https://horde.grubit.at

After this I tried to get Horde to work using an openSUSE VM. I have 
such a VirtualBox VM running on my home computer for test purposes. 
After having added some needed modules and other stuff I got apache2 to 
work on that VM. Additionally I had to set up the mysql server and to 
install composer on the VM.

On that VM there was never Horde installed or PEAR.

Now I could install Horde with composer and copied the sample config 
file to conf.php and called

cd /srv/www/htdocs/horde
composer horde-reconfigure

I opened the web browser in the VM and called http://localhost/horde/web

Now I expected the installation wizard or something similar. But instead 
of that I get redirected to this address:


So the same thing happens as on my production server.

I'm sorry, I suspect a bug in Horde's PHP code that only appears in 
SUSE. How can I debug this?


Regards from Austria
Ferdinand Gruber

More information about the horde mailing list