[horde] Cannot install Horde with composer on openSUSE 15.4

Brent impuser at bitrealm.com
Sun Feb 5 23:49:00 UTC 2023

  Quoting Ferdinand Gruber <fer.grub at yahoo.de>:

> I've been using Horde for almost 20 years now. PHP8 was installed  
> with the upgrade to Suse 15.4. Since upgrading to PHP8, Horde has  
> stopped working.
> Now I tried a new install of Horde with composer. I am sure that I  
> did everything correctly according to the instructions on github. I  
> also created a virtualHost for Horde using /srv/www/htdocs/horde/web  
> as documentRoot
> After successful installation I think, that something like an  
> installation wizard should appear after calling the Horde site in  
> the web-browser. But instead I am redirected to a login page, that  
> of course does not exist.
> You can examine this on my real site: https://horde.grubit.at
> After this I tried to get Horde to work using an openSUSE VM. I have  
> such a VirtualBox VM running on my home computer for test purposes.  
> After having added some needed modules and other stuff I got apache2  
> to work on that VM. Additionally I had to set up the mysql server  
> and to install composer on the VM.
> On that VM there was never Horde installed or PEAR.
> Now I could install Horde with composer and copied the sample config  
> file to conf.php and called
> cd /srv/www/htdocs/horde
> composer horde-reconfigure
> I opened the web browser in the VM and called http://localhost/horde/web
> Now I expected the installation wizard or something similar. But  
> instead of that I get redirected to this address:
> http://localhost/horde/login.php
> So the same thing happens as on my production server.
> I'm sorry, I suspect a bug in Horde's PHP code that only appears in  
> SUSE. How can I debug this?
> --
> Regards from Austria
> Ferdinand Gruber

As I've said, I have horde (dev6) working on Opensuse 15.4 and php  
8.0. I also did a force upgrade to php 8.1 and Horde continued to  
function just fine on Opensuse 15.4. Try to install at least one  
component, preferably Imp and see if that installs other modules that  
you might be missing.


$  composer require horde/imp dev-FRAMEWORK_6_0

When I go to your site like this:


I'm getting an Auth driver not found. This is because there is no  
cookie being set for Horde_Auth. I'm a little unclear why that would  
happen, offhand. I see Net_DNS2 is also missing, but that will be  
installed if you add the "imp" package.

Going to your site:


...without a trailing path, it is redirecting without the  
hostname...somehow it is NULL. I've tried all manner of weird things  
on my OpenSUSE installation to try to get the system to NOT return the  
hostname and I can't seem to reproduce that odd behavior.


More information about the horde mailing list