[horde] Cannot install Horde with composer on openSUSE 15.4

Ferdinand Gruber fer.grub at yahoo.de
Thu Feb 9 23:01:45 UTC 2023

Am 09.02.23 um 02:48 schrieb Brent:
>  Quoting Ferdinand Gruber <fer.grub at yahoo.de>:
>> Am 06.02.23 um 19:50 schrieb Brent:
>>>  Quoting Brent <impuser at bitrealm.com>:
>>>> Quoting Ferdinand Gruber <fer.grub at yahoo.de>:
>>>>> Am 06.02.23 um 00:49 schrieb Brent:
>>>>>>  Quoting Ferdinand Gruber <fer.grub at yahoo.de>:
>>>>>>> I've been using Horde for almost 20 years now. PHP8 was 
>>>>>>> installed with the upgrade to Suse 15.4. Since upgrading to 
>>>>>>> PHP8, Horde has stopped working.
>>>>>>> Now I tried a new install of Horde with composer. I am sure that 
>>>>>>> I did everything correctly according to the instructions on 
>>>>>>> github. I also created a virtualHost for Horde using 
>>>>>>> /srv/www/htdocs/horde/web as documentRoot
>>>>>>> After successful installation I think, that something like an 
>>>>>>> installation wizard should appear after calling the Horde site 
>>>>>>> in the web-browser. But instead I am redirected to a login page, 
>>>>>>> that of course does not exist.
>>>>>>> You can examine this on my real site: https://horde.grubit.at
>>>>>>> After this I tried to get Horde to work using an openSUSE VM. I 
>>>>>>> have such a VirtualBox VM running on my home computer for test 
>>>>>>> purposes. After having added some needed modules and other stuff 
>>>>>>> I got apache2 to work on that VM. Additionally I had to set up 
>>>>>>> the mysql server and to install composer on the VM.
>>>>>>> On that VM there was never Horde installed or PEAR.
>>>>>>> Now I could install Horde with composer and copied the sample 
>>>>>>> config file to conf.php and called
>>>>>>> cd /srv/www/htdocs/horde
>>>>>>> composer horde-reconfigure
>>>>>>> I opened the web browser in the VM and called 
>>>>>>> http://localhost/horde/web
>>>>>>> Now I expected the installation wizard or something similar. But 
>>>>>>> instead of that I get redirected to this address:
>>>>>>> http://localhost/horde/login.php
>>>>>>> So the same thing happens as on my production server.
>>>>>>> I'm sorry, I suspect a bug in Horde's PHP code that only appears 
>>>>>>> in SUSE. How can I debug this?
>>>>>>> -- 
>>>>>>> Regards from Austria
>>>>>>> Ferdinand Gruber
>>>>>> As I've said, I have horde (dev6) working on Opensuse 15.4 and 
>>>>>> php 8.0. I also did a force upgrade to php 8.1 and Horde 
>>>>>> continued to function just fine on Opensuse 15.4. Try to install 
>>>>>> at least one component, preferably Imp and see if that installs 
>>>>>> other modules that you might be missing.
>>>>>> Do:
>>>>>> $  composer require horde/imp dev-FRAMEWORK_6_0
>>>>>> When I go to your site like this:
>>>>>> https://horde.grubit.at/horde/login.php
>>>>>> I'm getting an Auth driver not found. This is because there is no 
>>>>>> cookie being set for Horde_Auth. I'm a little unclear why that 
>>>>>> would happen, offhand. I see Net_DNS2 is also missing, but that 
>>>>>> will be installed if you add the "imp" package.
>>>>>> Going to your site:
>>>>>> https://horde.grubit.at
>>>>>> ...without a trailing path, it is redirecting without the 
>>>>>> hostname...somehow it is NULL. I've tried all manner of weird 
>>>>>> things on my OpenSUSE installation to try to get the system to 
>>>>>> NOT return the hostname and I can't seem to reproduce that odd 
>>>>>> behavior.
>>>>>> Thanks!
>>>>> I installed imp without errors on horde.grubit.at and on my VM but 
>>>>> that changed nothing.
>>>>> I don't get it to work neither on my production site nor on my 
>>>>> SUSE VM. I always get redirected to that strange login page.
>>>>> Thank you for trying to help me.
>>>>> -- 
>>>>> Regards from Austria
>>>>> Ferdinand Gruber
>>>>   The ""strange login" page you mention is happening because 
>>>> something is stripping out the hostname and being set as NULL in 
>>>> the url on the redirect to horde/login.php. I've no idea what that 
>>>> might be in your case.
>>>> Enable logging (debug/info) in Horde and see if anything 
>>>> "interesting" is showing up. If you edit your main "conf.php", 
>>>> you'll want to log to a file that has write access for the web 
>>>> user. You COULD start with logging priority "INFO" first, then go 
>>>> to "DEBUG" if nothing interesting is showing up.
>>>> $conf['log']['priority'] = 'DEBUG';
>>>> $conf['log']['ident'] = 'HORDE';
>>>> $conf['log']['name'] = '/logs/horde.log';
>>>> $conf['log']['params']['append'] = true;
>>>> $conf['log']['params']['format'] = 'default';
>>>> $conf['log']['type'] = 'file';
>>>> $conf['log']['enabled'] = true;
>>>> Brent
>>> I also see that the webuser can't write to the static directory on 
>>> your production server:
>> Sorry,  Iforgot to change the permissions after installation. Now I 
>> changed the ownership of all the files in/srv/www/htdochs/horde to 
>> wwwrun.www
>> But that did not change anything for me.
>> Now I tried a few things:
>> I copied the above config settings into 
>> horde/var/config/horde/conf.php. This is now the content of that file:
>> $conf['log']['priority'] = 'DEBUG';
>> $conf['log']['ident'] = 'HORDE';
>> $conf['log']['name'] = '/var/log/horde.log';
>> $conf['log']['params']['append'] = true;
>> $conf['log']['params']['format'] = 'default';
>> $conf['log']['type'] = 'file';
>> $conf['log']['enabled'] = true;
>> if (!defined('HORDE_BASE')) define('HORDE_BASE', 
>> '/srv/www/htdocs/horde/web/horde');
>> ini_set('include_path', 
>> '/srv/www/htdocs/horde/vendor/horde/autoloader/lib:/srv/www/htdocs/horde/vendor/horde/form/lib/:' 
>> .  ini_get('include_path'));
>>        require_once('/srv/www/htdocs/horde/vendor/horde/core/lib/Horde/Core/Nosql.php'); 
>>        require_once('/srv/www/htdocs/horde/vendor/autoload.php');
>> But that does also not change anything.
>> I suppose, that there could be something wrong with the apache2 
>> configuration.
>> I tried the directive UseCanonicalName = On in the virtualHost config 
>> file. But that also did not change anything.
>> -- 
>> Regards from Austria
>> Ferdinand Gruber
>> -- 
>> Horde mailing list
>> Frequently Asked Questions: http://horde.org/faq/To unsubscribe, 
>> mail: horde-unsubscribe at lists.horde.org
> I'm getting an error on your test.php page: 
> https://horde.grubit.at/horde/test.php
> Required Configuration Files
>     config/conf.php: No
>     The file config/conf.php is outputting a non-empty string when 
> parsed. Configuration files should not output anything. Output string:
>     Hostname: horde.grubit.at

Sorry for that. I tried something to find out, what happens and then I 
forgot to remove that again. I tried, whether $_SERVER["SERVER_NAME"] is 
retrieving the hostname.

> I DO see the imp login page test now work, sorta. 
Maybe you called the site, when I was trying the old horde installation. 
Sorry, I cannot really remember, what I tried the last days.
> I think you might be getting close!

No, I DO NOT see the imp login page and NO INSTALLATION WIZARD appears. 
I am still beeing redirected tohttp://horde/login.php

I am sorry, I have the suspicion, that the redirection happens in 

I have some sites on this server (Joomla, Worpress, own databased PHP 
projects). Some of the virtualHosts are IP based and others are name 
based. I cannot remember special problems with redirection.

I've been managing this server using openSUSE for almost 10 years now.

Regards from Austria
Ferdinand Gruber

More information about the horde mailing list