[horde] Cannot install Horde with composer on openSUSE 15.4

Ferdinand Gruber fer.grub at yahoo.de
Fri Feb 17 16:17:10 UTC 2023

Am 16.02.23 um 10:22 schrieb Admin Beckspaced:
> I encountered an issue with running composer as root.
> Do not run Composer as root/super user! See 
> https://getcomposer.org/root for details
> Continue as root/super user [yes]?
> If I just confirmed with yes and run composer the horde installation 
> was not working properly.
> Seems like some plugins were disabled as mentioned here: 
> https://getcomposer.org/doc/faqs/how-to-install-untrusted-packages-safely.md
> If I then instead do 'export COMPOSER_ALLOW_SUPERUSER=1' in the shell  
> and then run composer install the horde installation was properly 
> installed.

Ah, this is a new aspect of my problems with installation of Horde6 
using composer.

I did not mention, that composer should not run under the user roor. To 
be honest, I didn't know, that this is important. But this restriction 
is understandable.

Now I tried a new installation of Horde as root.
Before i set the envirionment variable: export COMPOSER_ALLOW_SUPERUSER=1

But unfortunately that didn't change anything. My request is still being 

I tried the issue on my home computer:

Request: horde.localnet

The horde wizard does not appear. I get still redirected to the non 
existing http://horde/login.php


Regards from Austria
Ferdinand Gruber

More information about the horde mailing list