[horde] Cannot install Horde with composer on openSUSE 15.4

Brent impuser at bitrealm.com
Fri Feb 17 17:16:40 UTC 2023

  Quoting Ferdinand Gruber <fer.grub at yahoo.de>:

> Am 16.02.23 um 10:22 schrieb Admin Beckspaced:
>> I encountered an issue with running composer as root.
>> Do not run Composer as root/super user! See  
>> https://getcomposer.org/root for details
>> Continue as root/super user [yes]?
>> If I just confirmed with yes and run composer the horde  
>> installation was not working properly.
>> Seems like some plugins were disabled as mentioned here:  
>> https://getcomposer.org/doc/faqs/how-to-install-untrusted-packages-safely.md
>> If I then instead do 'export COMPOSER_ALLOW_SUPERUSER=1' in the  
>> shell  and then run composer install the horde installation was  
>> properly installed.
> Ah, this is a new aspect of my problems with installation of Horde6  
> using composer.
> I did not mention, that composer should not run under the user roor.  
> To be honest, I didn't know, that this is important. But this  
> restriction is understandable.
> Now I tried a new installation of Horde as root.
> Before i set the envirionment variable: export COMPOSER_ALLOW_SUPERUSER=1
> But unfortunately that didn't change anything. My request is still  
> being redirected.
> I tried the issue on my home computer:
> Request: horde.localnet
> The horde wizard does not appear. I get still redirected to the non  
> existing http://horde/login.php
> Ferdinand
> --
> Regards from Austria
> Ferdinand Gruber

As I said, you don't NEED to run it as root, but you can. It is not  
recommended because if the composer/git project becomes compromised,  
then the evil-doers could add scripts that would be executed as root.  
Best to run as a non-privildged user, of course. The user running  
composer needs full write access to the horde subtree as it creates  
symlinks back to the installation directory.

@Ferdinand: when I check your test.php, I see that there is NO session  
cookie being set when I access your site. Horde should set a "horde"  
session cookie and it uses that for access. This is why I get the  
Horde_Auth driver not found when I go to:   
https://horde.grubit.at/horde/login.php.   I've tried messing around  
with my installation to prevent a session cookie, but no luck so far.  
If I could look at your VM, then maybe I could help sleuth the issue.

Session cookies might be trying to be written to /var/lib/php8; but,  
even if I make that directory read-only or unavailable on my test  
system, I still get a session cookie.

It probably has more to do with your apache2 configuration, somehow.


More information about the horde mailing list