Please re-instate 'protocol' => 'imap' (was Re: [imp] IMP RC-3 login problem)

Steve Lidie sol0@Lehigh.EDU
Fri, 31 May 2002 14:00:13 -0400

> I didn't follow the whole thread, so can you please summarize under which
> conditions it didn't work. There also have been several reports about imap
> without /notls didn't work and I guess it depends on the versions of one
> to-be-found component. c-client perhaps?
Wish I could be more specific.  My configuration is a RH 7.2 machine w/all
patches as of ~= 10 May.  At that time, I carefully read all the install 
and got horde 2.1-RC2, IMP 3.1-RC2, turba 1.1-RC2 running.  servers.php said
use -protocol => imap, which I did, and things worked (essentially) 

When RC3 of the above modules arrived, I carefully diffed the distributions,
noted that servers.php now said use protocol => imp/notls.  (I have no idea
what notls is.)  I was unable to login.  I scoured all the logs I could find
but turned up no useful information, and asked for help here:

I then discovered I could change the login screen so I could try various 
of imp-imap/ssl, etc.  That, of course, led me down the road to darkness.  
I even tried
changing the protocol to plain imap in server.php, but as I previously 
mentioned, this was
actually being overridden because of the menu change w/o me knowing it 
(until today, when
I leaned enough PHP to instrument ...lib/IMP.php (;).

Once Chuck suggested that same change yesterday in:

I looked harder and found the above problem.

So, what specifics can I provide, other than:

impad-2001.309 (UW)

So to be so long-winded ...