[imp] Occasional login failures

Thu Nguyen t.nguyen@unimelb.edu.au
Mon, 17 Jun 2002 10:36:33 +1000


After a weekend of observation, I can confirm these points:

* I did not have a single failure the whole weekend, then started to have a 
lot of them Monday morning.  That is when people come to work and use other 
clients to download their mail.  So it is the people who are away from 
their offices and need to read their mail (which is the purpose of the 
whole IMP project) that  suffer.
* When failure starts to occur, size of mail boxes seems to play a role in 
our case, but I have had failures with empty boxes as well
* Yes we use qpopper .

So if a typical failed login produce theses entries in the log:

Jun 17 09:47:52 HORDE [notice] [imp] Login success for thu [128.250.##.#] 
to {mailserver.subnet.unimelb.edu.au:110} [on line 51 of 
Jun 17 09:48:02 HORDE [error] [imp] FAILED LOGIN 128.250.##.# to 
mailserver.subnet.unimelb.edu.au:110[pop3] as thu [on line 332 of 

I reckon we will be looking at the IMP.php to modify, right?

Any useful hint?  Thanks a lot beforehand

At 05:37 PM 6/14/02 +0100, Carlton Thomas wrote:

>This seems to be similar to problems we experienced when
>using IMP against our POP server. No one was able to offer any
>assistance to resolve the problem, but I did post a message to the
>list with details of how we managed to overcome the problem. In short,
>we had to modify the PHP source to implement retries whenever IMP tried
>to authenticate against the POP server. If your problem is the same as
>ours, then you will see two entries in the POP server log. The first
>entry will show a successful authentication and the second entry will
>show a failure to authenticate. However, the failure only occurs if
>the second authentication attempt takes place while the POP server is
>still busy servicing the first attempt, ie. while the mailbox is locked.
>We also noticed that the number of authentication failures increased as
>the size of the mailboxes increased and when the load on the mailserver
>One thing to check, is whether you encounter the same authentication
>problems when you use the IMP demonstration program on the Horde site
>to access one of the problem mailboxes. When we tried that, we had the
>same authentication problems as we did from a local copy of IMP.
>One other thing to add is that we are using the QPopper POP3 server.
>I wonder whether the way QPopper handles large mailboxes is the source
>of the problem. Which POP3 server are you using?
>Regards !
>Bristol, United Kingdom
>Tel: 0845 111 0032
>Tel: 0117 939 7722
>Fax: 0845 111 0033
>Email: admin@gifford.co.uk
>Web: http://www.gifford.co.uk
>On Fri, 14 Jun 2002 t.nguyen@unimelb.edu.au wrote:
> > Hi Jan
> >
> > Every entry for a failed login is preceeded be a success entry:
> >
> > Jun 14 15:58:05 HORDE [notice] [imp] Login success for thu 
> [128.250.xx.x] to
> > {mailserver.mysubnet.unimelb.edu.au:110} [on line 51 of
> > "/usr5/kle/horde-2.0/imp/redirect.php"]
> > Jun 14 15:58:15 HORDE [error] [imp] FAILED LOGIN 128.250.xx.x to
> > mailserver.mysubnet.unimelb.edu.au:110[pop3] as thu [on line 332 of
> > "/usr5/kle/horde-2.0/imp/lib/IMP.php"]
> >
> > I have the feeling my Auth is confused between the horde and imp, but I 
> have
> > followed instruction to have imp to do Auth.  I have nothing else in 
> horde for
> > the moment, only IMP