[imp] Login problem in IMP

Ole Wolf wolf@blazingangles.com
Tue, 18 Jun 2002 07:57:02 +0200 (CEST)

I'm having a problem logging into IMP on a RedHat 7.3 machine.  Horde is 
version 2.1, and IMP is version 3.1, that is, the most recent version as 
of this writing.

The horde config file uses horde's own login, that is, I'm required to 
login twice to access mail.  That's fine for now.

When I login horde and IMP running my web browser as root, then I can
access my (non-root) mailbox without problems.  However, when I start my
web browser as a non-root user, then I can still login to horde, but as
soon as I try to go to the mail screen clicking on the "Login to mail"
link under the mail summary, I'm greeted with the following text:

Not Found

The requested URL /horde/imp/redirect.php was not found on this server.

Note again, this happens only when I run the web browser as non-root.

Using IMP as the default login (uncommenting the two lines in 
registry.php) changes the error to "/horde/imp/login.php" instead, but 
only for non-root users.

So, I thought it might have to do with permissions.  Since apache is
running as user "nobody," I've set all permissions to nobody.root to horde
(using chown -R nobody.root horde), and I've made sure that directories
have rwxr-xr-x permissions and files have rwxr-x-r-x permissions.  
Various combinations of chown -R apache.nobody, apache.root, etc. didn't 
yield any results.

I've also tried to run the set_perms.sh script, but that didn't cause any
changes.  I've followed the installation instructions in docs/INSTALL, but
installing the entire thing over again doesn't solve my problem.

There's one thing I'm suspecting might be wrong, but I've no idea how to
do anything about it, and the fact that everything works with user "root,"  
I doubt it that's the case:  horde and IMP are running on a local server,
which fetchmails all of my mail from my "blazingangles.com" domain
provider's mail server.  I can access the apache web server on that
machine using a "machine.blazingangles.com" subdomain ("machine" is not
the real name), so that in theory I could read my mail from work that way.  
I thought that horde might be looking for a file located on
"blazingangles.com," which obviously it won't find, because that's an
entirely different machine than "machine.blazingangles.com".  But again,
this doesn't seem to be the case.

I'm in the dark here.  Can anyone think of anything I'm doing wrong?


 - wolf -