[ingo] problem writing sieve file

Ted ted at easydns.com
Tue Dec 17 22:52:06 UTC 2019


OK, well I opened that port up and the connection is now getting 
through, but it seems from the logs that ingo isn't sending the whole 
email address as the user when it is trying to login

Dec 17 22:24:22 ezd04-pco dovecot: managesieve-login: Error: proxy: host 
not given: user=<ted>, method=PLAIN,

compared to the successful access from webmail generally:

Dec 17 22:23:58 ezd01-pco dovecot: imap-login: 
proxy(ted at hosehead.ninja): started proxying to x.x.x.x:143: 
user=<ted at hosehead.ninja>, method=PLAIN,

with only ted given as the user the proxy can't get the correct host and 
authentication would fail anyway.  Is there something I need to include 
in the ingo configs so that it will send the whole address as the user?

Thank you
easyDNS Technologies

On 12/16/19 3:06 PM, Patrick Boutilier wrote:
> On 12/16/19 2:55 PM, Ted wrote:
>> Hello,
>> I'm working on a horde implementation for our mail system, and I'm 
>> having problems with getting ingo to be able to write to the sieve 
>> file to the server, I get a connection time out error whenever I try 
>> to save a filter.  Horde can access email on the same server it's 
>> trying to write the file to, and all other functions seem to work.
>> My backends.local.php is as below:
>> <?php
>> $backends['imap']['disabled'] = true;
>> $backends['sieve']['disabled'] = false;
>> $backends['sieve']['transport'][Ingo::RULE_ALL]['params']['hostspec'] 
>> = 'imap.easymail.ca';
>> $backends['sieve']['script'][Ingo::RULE_ALL]['params']['utf8'] = true;
>> That mailservers are loadbalanced and also run through a director 
>> proxy, so the imap.easymail.ca host points to a loadbalanced 
>> director-dovecot cluster which handles login requests and directs to 
>> the backend servers which actually maintain the mail and sieve files, 
>> I had tried having ingo connect  directly to one of the director 
>> machines and directly to one backend server to see if something in 
>> the networkng was a problem, but I get the same result regardless.  
>> I'm wondering if there is something needed in the config I'm unaware 
>> of, or what else to check at this point.  Can anyone offer any 
>> insight or suggestions?
> Is the sieve port (either 2000 or 4190) open internally? Definitely 
> isn't on imap.easymail.ca from the Internet.
>> Thanks
>> Ted
>> easyDNS Technologies

More information about the ingo mailing list