[nag] Cannot add, edit or delete tasks

horde@martycombs.com horde@martycombs.com
Wed, 15 May 2002 09:33:45 -0700 (PDT)

I can find no error message on the screen or in the horde logfile.  I can
click on the "Add Task" link and enter all information.  When I click on
save, the browser frame blinks and returns to the "List Tasks"  screen.
If there is an error message, it flashes by so quickly I don't see it.  I
have all javascript, java, and cookies turned on.  This behavior occurs in
both Mozilla 0.9.9 and Netscape 4.77.

I'm now running mysqld with query logging turned on.  In the "List Tasks"
screen I see a nag passing a "select *" to mysql.  After entering all
information for a new task and clicking the save button the browser frame
blinks quickly and returns to the "List Tasks" screen.  The mysql log
shows never shows an insert command, only another "select *" for list

Below is an exert from the mysql logs between the last 2 select
statements, I had tried to add a new task and got no response.
                     16 Init DB     horde
                     16 Query       SELECT pref_scope, pref_name,
pref_value FROM horde_prefs where pref_uid = 'imptest@localhost' and (pref_scope = 'nag'
or pref_scope = 'horde') order by pref_scope
                     16 Statistics
                     16 Init DB     horde
                     16 Query       select * from nag_tasks where task_owner = '
020515  8:33:36      17 Connect     horde@localhost on
                     17 Init DB     horde
                     17 Query       select * from nag_tasks where task_owner = '
020515  8:33:50      18 Connect     horde@localhost on
                     18 Init DB     horde
                     18 Query       select * from nag_tasks where task_owner = '

I've tried dropping the table and re-adding it in mysql, removing all of
nag and re-checking it out from cvs (and re-configuring it).  Nothing
seems to work.

marty :-(

On Wed, 15 May 2002, Jan Schneider wrote:

>Zitat von horde@martycombs.com:
>> Neither nag nor mnemo will allow me to add a task.  My setup is:
>>   * RedHat 7.2,
>>     PHP 4.1.2 (compiled from tarball),
>>     MySQL 3.23.41 (via rpm)
>>   * Installed from a CVS download
>>   * Horde authenticates vi imap on localhost
>>   * nag/config/conf.php is setup to connect to mysql on localhost as
>>     user 'horde' password 'horde'
>> The nag_tasks table is setup in the horde database.  The only change I
>> made to the included sql script was to connect to the horde database.
>> All the grant permissions appear to be set because I can connect to
>> the nag_tasks table from the mysql command-line with the same
>> username/password (horde/horde) and add the task with the insert
>> command.  I can even view the manually created task but cannot changes
>> or delete it.
>> Other connections to mysql work since I can change my preferences.
>> I've run out of ideas.  Any help is appreciated.
>What does actually happen if you try to add a task? Error message, back to
>the edit screen, redirect to another screen, browser crashes,...?
>http://www.horde.org - The Horde Project
>http://www.ammma.de - discover your knowledge
>http://www.tip4all.de - Deine private Tippgemeinschaft