[turba] Problem to convert a public source (turba <= 2.0.x) to a shared source (turba >= 2.1)

Michael Rubinsky mike at theupstairsroom.com
Thu Nov 30 09:37:24 PST 2006

Quoting Yvon Lafaille <yvon.lafaille at limousin.iufm.fr>:


> ...
> I converted this source with the script  
> "turba/scripts/upgrades/public_to_horde_share.php"
>     owner : Administrator      Title : Public Addresses;
>    Source : publicsql
>    [   OK   ] Created new Horde_Share object for the shared address book.
>    [  INFO  ] Moving 348 contacts to Public Addresses.
>    *** Public Addresses successfully created ***
>    Share Info:
>        Title: Public Addresses
>        Owner: Administrator
>        uid:   6d7e5b3d4a6bcb349780c4d5a738f5ba
> At this point, I still see the "publicsql" address book  with the  
> old title : "Adresses Publiques".
> But a listing of this address book or a search in this adress book  
> give no result.
> In fact the old public address book is still showing but has become unusable.
> The address book with the new title : "Public Adresses" is not  
> showing anywhere.
> It is why I am unable to work with this address book or edit the  
> Permissions of  this address book
> Please help.

I'll try...

I just tried this on my dev install, and it worked fine.  SO, I'll  
need a little more info to try to figure out what is going on here.

First, let's try the simple things...check in your user options,  
Options->Address Books->Choose which address books to display...
Make sure that the newly created public address book is listed in the  
right hand window, and the old one is not.  In your email, you did not  
indicate if you had the script update user prefs or not (only sql  
prefs backends can be updated by the script).  If the script does not,  
or can not, update the prefs then any users that have set this setting  
in the past will need to reselect their prefs for this before the new  
source will show up.  My money is on that this is what is going  
on...but I'm known for my bad bets ;)

If not, let us know and we'll continue to work this with you.


The Horde Project (www.horde.org)
mrubinsk at horde.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-keys
Size: 2013 bytes
Desc: PGP Public Key
Url : http://lists.horde.org/archives/turba/attachments/20061130/5e0aa1d4/attachment.bin

More information about the turba mailing list