[whups] Whups as Helpdesk CVS Diff

mbydalek at mobilemini.com mbydalek at mobilemini.com
Thu Oct 28 10:09:30 PDT 2004


All:

I have to say that what everyone has done to Whups has been great! A while
ago, back in June/July, I had brought up how I modified Whups a little to
make it more of a Tech. Support Helpdesk, like for a company, campus, etc.
rather than a Project Ticket System.  This week, I needed to add a lot of
features and decided to update.

So, I cvs'd and applied my changes (which is actually 1/4 of the total code
due to the improvements made) and have a CVS Diff ready to go (as of 5 mins
ago).

First let me say my goals for the system as it will explain a lot of what I
have done.

1) Keep track of ticket creator information.  Since we have to comply to the
Sarbanes-Oxley system, we *have* to keep track of who created a ticket, and
who commented on that ticket, etc., so the guest system wouldn't work.

2) Not have users login to create a ticket.  We have a ton of people and
getting them to login just would not work.  If I could, then #1 would have
already been solved.

3) Have User information in a single location.  I didn't really want 2
versions of user information floating around, so I decided to use Turba to
house that info (since I can integrate into our current system via. Ldap).

There are some processes that I have changed, so let me go over them now.

* Turba is integrated to keep track of user information.  What I did was
store the Turba ID as the ticket's user_id_requester.  Each time it was
referenced, I just did a getContact (actually a Whups function) to get their
information to display.

* When a ticket is created from a guest point of view, I have them just type
in their userid (which happens to also be their e-mail 'userid at domain.com').
This goes back to the lazy factor and people would be up in arms if they had
to type in their entire e-mail address.

* The block layout (along with mybugs) has an "Unassigned Tickets" listing
so you can see all the tickets that haven't been picked up yet only from the
queues which you are responsible for.  I also modified it to display extra
information about the ticket specifically relating to the user.

* Added a "Take Ticket" link to make it easier to actually grab a ticket
from the queue.

* Added Whups_Ticket::ticketNumberFormat() to make the tickets a little
easier to read as I created a custom numbering system (BranchID - year -
ticketID).

* The update tab was changed to allow a ticket to go back into the queue if
the person wasn't able to handle it, accidentally grabbed it, etc.

* The update tab actually makes you an owner if you choose "Assigned" - but
it's hardcoded which at the moment I don't like, but it works.

* A purely custom addition was that of using the turba field ['branchid']
throughout random parts of the code.  This is because we have a lot of
branches so this helps us sort out tickets.  Of course this should be
removed for general usage.

A lot of the things I've done may seem silly, or pointless, but in reality
this system has worked beautifully for us for the past several months.
Additionally, it's saved the company thousands as other products like HEAT,
etc. are extremely expensive.

Take it for what you will, and let me know if you have any questions on why
I did something the way I did.

Regards,
Mike Bydalek

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cvs.diff
Type: application/octet-stream
Size: 18059 bytes
Desc: not available
Url : http://lists.horde.org/archives/whups/attachments/20041028/d7458a32/cvs.obj


More information about the whups mailing list