[whups] Can't view tickets after cvs update

Ronny Adsetts ronny.adsetts at amazinginternet.com
Wed Jul 13 02:48:09 PDT 2005

Chuck Hagenbuch said at 11/07/2005 20:06:

> Quoting Ronny Adsetts <ronny.adsetts at amazinginternet.com>:
>>Having a bit of a whups problem. Got a FRAMEWORK_3 checkout, 
>>obviously whups on the HEAD. Did an update this morning and am seeing 
>>"There are no queues which you can search." on the tickets search 
>>screen for all users not named as horde admins.
>>I've tried removing and re-creating permisions for whups but it's not 
> Can you see if this helps:
> http://cvs.horde.org/diff.php/framework/DataTree/DataTree/sql.php?r1=1.200&r2=1.201&ty=u
> If not, please file a bug report on bugs.horde.org with as many details 
> as you can scrounge up.

This does indeed fix the problem - all my users can now see tickets again :-D

The permissions control for whups still doesn't seem to do what I think it should though.

For example, setting authenticated users to show/read/edit then adding a group permission of show/read/edit/delete doesn't allow members of that group to move tickets between queues. Nor can they delete tickets.

I've not had time to dig in to this yet but it's on course to become an issue so I will at some point... is this something that you're aware of? I assume it should work as I expect?

Thanks for the continued hard work BTW, it's much appreciated.

Technical Director
Amazing Internet Ltd, London
t: +44 20 8607 9535
f: +44 20 8607 9536
w: www.amazinginternet.com

More information about the whups mailing list