[horde] Two problems

Peter Filias peter at filias.com
Thu Sep 25 06:31:42 PDT 2003

I know these have been covered extensively in the archives, and God knows,
I've searched the entire 23MB archive .mbox file with no luck to a true
solution to this. I'm going to be as detailed as possible with my problem.

Horde version: 2.1
IMP version: 3.1

PHP version: 4.3.1
    * FTP Support: Yes
    * Gettext Support: Yes
    * IMAP Support: Yes
    * LDAP Support: No
    * MCAL Support: No
    * Mcrypt Support: No
    * MySQL Support: Yes
    * PostgreSQL Support: No
    * XML Support: Yes

    * PEAR - Yes
    * Recent PEAR - Yes
    * Mail::RFC822 - Yes
    * Log - Yes
    * DB - Yes

Yesterday, I thought it'd be fun to try and install that LATEST Horde and
IMP. Well, I had no luck, as I needed to do some things to my PEAR and PHP
installations (DOMXML) and I was unable to do it, and my host (CI HOST),
wouldn't help me out, as they said DOMXML was experimental. Oh well, so I
resorted to my backed up copy of Horde/IMP (I saved the entire directory,
so I figured it'd be easy to "go back"). Well. I couldn't do that either,
and started to get errors. I am probably getting some of these errors
because I messed w/ my PEAR installation. I decided to go back to the
Horde and IMP versions listed above.

Now, here is my situation:

I can get to my Horde page no problem (http://www.filias.com/horde), I can
even log in with no problem. I am using IMAP to do my authentication. All
I want Horde for, at the moment, is IMP. I don't want to have to go and
create a bunch of Horde users. I had it like this two days ago (and going

What's NEW to me is that when I log into Horde (I used to log into IMP
(http://www.filias.com/horde/imp), I get my Mail link with the inbox link.
Clicking the inbox works, but clicking "Mail" doesn't work. When I click
Mail, I get the following error, which is the same error I get when I try
to make any preferences changes: Fatal error: Call to undefined function:
iswarning() in /home/www/filias/horde/lib/Prefs/sql.php on line 101

These are my conf prefs settings in horde.php:
$conf['prefs']['params']['phptype'] = 'mysql';
$conf['prefs']['params']['hostspec'] = 'localhost';
$conf['prefs']['params']['username'] = '*';
$conf['prefs']['params']['password'] = '*';
$conf['prefs']['params']['database'] = 'horde';
$conf['prefs']['params']['table'] = 'horde_prefs';

In using phpMyAdmn, I can connect to this database just fine. I don't see
why Horde and IMP are having a problem with this.

*PLEASE* don't tell me to look at the archive, and please don't tell me to
use sql as the auth driver, as I have always used IMAP to auth and I even
tried sql to auth, and it still didn't work.

In looking at my horde.log file, I found this pertinent bit of info:
Sep 25 07:32:10 HORDE [emergency] [imp] Required 'phptype' not specified
in preferences configuration. [on line 80 of

However, I am not getting this error logged currently. It's now 856am, and
that only happened at 732a. I really want to get "back" to my previous
quality of service I had two days ago. Actually, the way I have Horde
installed now seems to be even better, as the bottom menu is there (Horde
Mail Logout). It didn't used to be. So I'm PART of the WAY there.

I appreciate everyone's help.

Peter Filias

More information about the horde mailing list