[horde] Installing the RC

Simon Brereton simon.brereton at dada.net
Tue Mar 29 23:16:29 UTC 2011

> From: horde-bounces at lists.horde.org [mailto:horde-
> bounces at lists.horde.org] On Behalf Of Simon Brereton
> > > Then I reinstalled PEAR.  But when I ran pear upgrade it upgraded
> a
> > > few and complained about a lot of horde errors like:
> > >
> > > Validation Error: File
> > > "js/syntaxhighlighter/scripts/shAutoloader.js" in directory "<dir
> > > name="/">" has invalid role "horde", should be one of cfg, data,
> > doc,
> > > php, script, test, www Validation Error: This package contains
> role
> > > "horde" and requires package "horde/Role" to be used
> >
> > The error message is pretty clear. Install and run horde_role
> *FIRST*,
> > like explained in the installation instructions.
> Jan - as you can see from below though, this was a fresh install of
> PEAR and and I hadn't even run the discover-channel command yet.
> Doing pear install horde/horde-role at this stage didn't help either.
> I'll attempt to completely remove pear again - and do the channel-
> discover and the install horde-role first...

Jan - I purged PEAR and rebooted

The I ran  these commands with the attached out-put.

root at jonty:~# pear channel-discover pear.horde.org
Adding Channel "pear.horde.org" succeeded
Discovery of channel "pear.horde.org" succeeded

root at jonty:~# pear install horde/horde_role-beta
downloading Horde_Role-1.0.0RC2.tgz ...
Starting to download Horde_Role-1.0.0RC2.tgz (2,281 bytes)
....done: 2,281 bytes
install ok: channel://pear.horde.org/Horde_Role-1.0.0RC2
horde/Horde_Role has post-install scripts:
Horde_Role: Use "pear run-scripts horde/Horde_Role" to finish setup.

root at jonty:~# pear run-scripts horde/horde_role
Including external post-installation script "/usr/share/php/PEAR/Installer/Role/Horde/Role.php" - any errors are in this script
Inclusion succeeded
running post-install script "Horde_Role_postinstall->init()"
init succeeded
Filesystem location for the base Horde application : /usr/share/horde4
Configuration successfully saved to PEAR config.
Install scripts complete

root at jonty:~# pear list-files horde/horde
`horde/horde' not installed

I'm pretty sure at this point it doesn't make sense to proceed - but I wish I knew how to further investigate the issue.  I really want the new Horde! :)


More information about the horde mailing list