[horde] User not authorized for mail - SOLVED

Jan Schneider jan at horde.org
Sat May 14 12:15:11 UTC 2016

Zitat von Dennis Terebecki <dtex23 at gmail.com>:

>> Hello all,
>> Using Horde 5.2.10, freshly installed,
>> I have an issue where two users are not being displayed the "Mail" link in
> their top menu bar.  I've >followed the recommended troubleshooting
> procedures in the FAQ at https://wiki.horde.org/faq/>admin/troubleshoot
> <https://wiki.horde.org/faq/admin/troubleshoot> and cannot seem to make
> headway.  Also, any options associated with Mail: >do not show up in the
> Add Content portal blocks.
>> Interestingly, I noticed that I have (fully functional, read, send,
> receive) mail displayed to me (the >administrator), so I promoted one of
> the other users to administrator, and mail started working for >them, with
> the ability to add the portal block, view, send and receive mail.  As soon
> as the user >was removed from the administrator group, the message "User
> xxx is not authorized for Mail >(Host: x.x.x.x)".
>> How to fix this so that a non administrator user is authorized to use
> Imp/Mail?
>> DJ
>> dtex23 at gmail.com <dtex23 at gmail.com>
> AHA!!!
> From searching, it looked like two things just about everyone from
> Google-space was saying that permissions were an issue ... and everyone
> posting back and forth was looking at *NIX filesystem permissions.  There
> are even some helpful souls pointing towards the storage backend and
> cookies (see https://wiki.horde.org/faq/admin/troubleshoot)
> Mine was solved in an easier fashion...
> (menu) Administration -> Configuration link
> (left side) Permissions
> (tree) All Permissions
> (tree) Mail (imp)
> (tree) Edit
> All Authenticated Users tab
> Check all boxes (show, read, edit, delete)
> click Update, and viola!
> According to the wiki page https://wiki.horde.org/Doc/Permissions   , "If
> there are no permissions set on an application, or on Horde itself, the
> default is to allow authenticated users and disallow guests (unless the app
> is disabled or set to admin-only in the registry)".  This does not seem to
> be the case, as users were explicitly denied imp login.  Also strange is
> the fact the imp is the only application that had permissions by default.
> Am I the only one to see this?  Is this something that needs to go in the
> wiki or install docs?  Two minutes of reading here is a hell of a lot
> easier than two days of headbanging pain. searching for something
> documentation suggests should be automatic.
> DJ

There are no default permissions set. If you had (empty) permissions  
created for IMP, you, or anybody else, must have explicitly created  

Jan Schneider
The Horde Project

More information about the horde mailing list