[whups] Trying to use whups for Horde problem reports

Lars Stavholm stava at telcotec.se
Tue Dec 26 05:14:23 PST 2006

Anders Norrbring wrote:
> Lars Stavholm wrote:
>> Anders Norrbring wrote:
>>> Hi.
>>> I'm trying to use whups for problem reporting in the Horde framework,
>>> but I don't have much success with it.
>>> In my horde/config/conf.php I have this:
>>> $conf['problems']['ticket_params'] = array('queue' => 1, 'state' => 1,
>>> 'priority' => 1, 'type' => 1);
>>> $conf['problems']['tickets'] = true;
>>> When I click a problem report button, I'm taken to the form to enter a
>>> problem description, name and e-mail address, I expected to find myself
>>> in a ticket entry form?
>> I think that the Problem Report and Tickets (Whups) are two
>> different things. The Problem Report is available even without
>> whups, as you could see in the new horde-webmail bundle.
>> When it comes to whups, I just tried out the CVS version from
>> 2006-12-19, and that worked to some extent, but not all the way.
>> I could set up queues and ticket types and whatnot, I could even
>> register a new ticket, db handler complained, but the ticket
>> shows up in the whups_tickets database table, but not in any
>> Ticket Searches.
> Yes, they're indeed different, however, if you go to Administration ->
> Setup -> Horde and then Problem Reporting, they even list example for
> using Whups with the problem reporting.. I did some Googling on it, and
> found notes from 2005 where the developers discussed how to enable this
> functionality, so my guess is that it can be done.. ;)

I just tried that, and after the setting you mentioned
above, the Problem Report does actually create a proper
ticket, whereas the user interface is still the standard
Problem Report one.

> I pulled cvs today (2006-12-26), and even built a RPM for SUSE Linux
> from it. I can't complain about anything about the module itself so far,
> it lists tickets, they're searchable and editable. But I haven't digged
> deeply into it yet.

Well, I haven't succeeded in getting it going properly, I get DB errors
and Ticket not found (despite the fact that they're there in the db).

If you wouldn't mind sharing, I'd be interested in how you built
the rpm. We build our own rpm's as well (SuSE Linux 10.1), but
obviously, I've done something wrong with the whups part.

/Lars Stavholm <http://www.linadd.org>

More information about the whups mailing list